jQuery Migrate 1.2.1 Released

Posted on by

They say there are no second acts in software … well, there are always second acts in software. Especially when the first act bombs. With that in mind, version 1.2.1 of the jQuery Migrate plugin has arrived. It can be used with either jQuery 1.9 or jQuery 2.0.

This minor update addresses regressions created by the security fix in the 1.2.0 release that rejected some valid HTML strings. Many thanks to GitHub users gerrod, basc, Leonya, krzyko, and lorddefinitia for reporting these issues.

You can find this latest version of the jQuery Migrate plugin on jQuery’s CDN:

Complete instructions and a complete list of the diagnostics given by the plugin are located in the plugin project’s README file.

A full list of all changes are in the issue tracker.

2 thoughts on “jQuery Migrate 1.2.1 Released

  1. Mike on said:

    Sorry for asking a question over this channel but i could not find a forum or mailing list dedicated to jquery migrate.

    Does Jquery.Migrate restores the support for Internet Explorer 6,7&8 to Jquery 1.9.x and 2.x ?

    If Yes, then this should be pointed out more direct in the documentation for Jquery.migrate.


  2. xzyfer on said:

    jQuery Migrate is just a shim for functionality that was removed in jQuery 1.9. It does not return old IE support to jQuery 2.0. jQuery 1.9 still supports old IEs.