jQuery UI 1.6rc5 Compatible with jQuery 1.3

Posted on by

jQuery UI 1.6rc5 is available.

Download jQuery UI 1.6rc5
You can download the entire development bundle directly


This includes a default theme, as well as all the test and demo files. Or you can create a customized download of individual components


and a custom theme at


Be sure to grab an updated 1.6rc5 theme, if you got a theme from ThemeRoller in the last two weeks. (Also, for any users of 1.5.3, there is a link on ThemeRoller for downloading legacy themes)

Compatibility with jQuery 1.3
Thank you to the many people that helped test and contribute fixes to make this release happen. We have fixed a lot of issues in the two weeks since rc4 and the most major fix is this release is compatible with jQuery 1.3 (Happy Birthday jQuery) where 1.6rc4 was only compatible with jQuery 1.2.6. From now on, we ask that 1.6rc4 is no longer used for testing. Also, from here forward jQuery UI 1.5.3 will only support jQuery 1.2.6. And jQuery UI 1.6 will only support jQuery 1.3+
Thanks for any help you can provide to ensure this release is ready and fully compatible with jQuery 1.3. Please create a ticket for any issue you find on the jQuery UI bug tracker:

http://ui.jquery.com/bugs (note: requires registration)

and send a note for discussion on the jQuery UI Development mailing list as well:


The current schedule is to wrap up 1.6 final by the end of next week.

27 thoughts on “jQuery UI 1.6rc5 Compatible with jQuery 1.3

  1. The date picker shows those foreign character blocks in FF3 when you click to the next month: 2009二月

  2. Pingback: Date Range Picker, llevando los selectores del fecha más allá : Blogografia

  3. Pingback: Data range picker con jQuery UI 1.6 | e-octante

  4. gokudomatic on said:

    end of this week? holy divinity! I’m so happy to hear it will release so soon. The disruption between jquery 1.3, jquery ui 1.5 and the themeroller 1.6 is actually giving a bad reputation to jquery at the worst moment. But I hope the result will be worth it.

  5. Although 1.6rc5 advertises compatibility with jq1.3, it seems to be broken… Theme roller is broken, the demos are broken… Trac is broken. What is happening?

  6. moondog on said:

    I welcome the news and the hard work!
    Unfortunately the oh-so-nice rounded corners disappear in ie: i know the reason why, but is there a quick clever way to fix it, already implemented, like some classes just waiting for 4 corner images…you know.. : )

  7. moondog on said:

    (2nd part!)
    There always seem to be a problem with Internet Explorer support: in the demo pages, the sliders look wrong (misplaced handle in the simple scrollbar) and lots of js errors, the slider with fixed range max shows often x.99999999999 instead of an integer value….

    Ok, it’s an rc, not the final version but I keep wondering if I can rely on the library, which is what it boils down to.

  8. is there going to be any improvements making the dialog more accessable? I still cannot tab to the dialog buttons.

  9. @mike.

    i have a dialog with just an okay button
    using 1.5.3, tabbing jumps between location bar and button

    using 1.6rc4 (haven’t got around to 5 yet) … tabbing jumps between X and okay

    both on FF3

  10. Tabs don’t work still – with 1.3.1 and this tabs don’t display properly

    They work fine in 1.2.6 against 1.5.3

    Do all the jQuery UI items get tested before release? This one hasn’t worked since 1.3 came out and I’ve posted a few times that it is broken?

  11. Pingback: Date Range Picker, llevando los selectores del fecha más allá | aNieto2K

  12. vikram on said:

    I used jQuery 1.2.6, now I tried to migrate to jQuery 1.3 so I have copied the jQuery 1.3 file and all the plugins for UI – 1.6rc5. But it seems like many of the things are broken..
    # Slider is throwing folowing error:
    too much recursion – jquery.js (line 2563)
    var namespace = RegExp(“(^|\\.)” + nam…ice().sort().join(“.*\\.”) + “(\\.|$)”);#
    too much recursion – jquery.js (line 2353)
    jQuery.event.handle.apply(arguments.callee.elem, arguments) :

    # DatePicker is also broken.

    Please suggest when the final bug-free version is going to release

  13. Regarding the latest (2009-02-05) themeroller: When creating a “Cupertino” theme (probably in others as well), one url() statement looks incorrect. In the Interaction States section, url(images/bg_glass_75_dadada_1x400.png), {bgImgUrlHover}, apparently should be url(images/ui-bg_glass_75_dadada_1x400.png) (missing “ui-” prefix in the png file name). All other png filenames in the url() wrapper follow that pattern. This affects Datepicker.

  14. animated/fading background colors seem to “stick” every now and then and I need to mouseover to “unstick” them and bring it back to the original color.

  15. Pingback: jQuery UI 1.6rc5 Compatible with jQuery 1.3 | Ajax Guru - How to Ajax

  16. Pingback: jQuery UI 1.7 « jQuery UI Blog

  17. Hi, i have copied the jQuery 1.3 file and all the plugins for UI – 1.6rc5. But it seems like many of the things are broken.

  18. Pingback: Twitted by lsj0104